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Overview



© Lattice Technology, Inc. All Rights Reserved. Table of Contents 4

Installation

1. Install XVL Player by double-clicking the installation file.
2. In the installation wizard, you can choose the default viewer application for XVL files.

* XVL files will be opened in the specified application when 
double-clicked.
* XVL files can be drag-and-dropped onto any of the 
applications for viewing.
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License Setup

* To activate XVL Player Pro or XVL Studio based features, 
the corresponding license file(s) must be installed.

To install a node-locked license file:
1. Select Start > All Programs > XVL Player (Ver. 9 or later) 

> License Folder to open the license folder.
2. Place the license file in the license folder.

To connect to a floating license server:
3. Right-click and select Help > License… to bring up the 

License dialog box.
4. Change the License source to License server.
5. Enter the Host name and Port No of the license server.
6. Select OK to save the changes.

2

3

4 5
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XVL Player Window

(1) Toolbar 
Frequently used functions such as view manipulations and 
controls are available here.

(2) Assembly Tree 
The assembly structure of the 3D model is displayed here. 

(3) Right Click Menus 
Most operations are available from right click menus.

(4) Graphic Window
Main place to operate on the 3D model.

(1)

(2)

(4)

(3)
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XVL Player Toolbars
XVL Player contains 9 different toolbars.

(2) File Toolbar

(3) View Toolbar

(4) Display Toolbar

(5) Operation Toolbar

(6) Measurement Toolbar

(7) Cross-section Toolbar

(8) Layout Toolbar

(9) Animation Toolbar

Edit Mode

View Mode

(1) Home Toolbar
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Home Toolbar

Home Toolbar (View Mode)

Home Toolbar (Edit Mode)

Animation tools

Snapshot
Cross-section tools

Measurement tools

Selection tools

Display Options

Display accuracy

Viewpoints Display Mode

Home icon resets the 
3D view. 

• The Home toolbar contains frequently-used tools.  The Home toolbar contains different tools for View mode and 
Edit mode.

• More tools are available on other toolbars.



© Lattice Technology, Inc. All Rights Reserved. Table of Contents 9

Opening an XVL File in XVL Player Application

To start up XVL Player:
1. Select XVL Player Application from the All Apps

menu.

To open an XVL file:
2. Select File > Open to open the Open dialog.
3. Select an XVL file to open.

XVL Player Application

2

3 4
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Viewing
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Viewing Operations 1/4

View Toolbar

Pan 3D model

3D rotation

Zoom in/out
Zoom in the specified area

Set gazing point
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Viewing Operations 2/4

View Toolbar

Top
Bottom

Isometric

Undo view change

Fit view

Front

Back

Right

Left

Rotate counter-
clockwise by 90 
degrees

Rotate  clockwise 
by 90 degrees
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Viewing Operations 3/4

Keyboard short cuts:
– Mouse + z: Pan 3D model
– Mouse + x: 3D rotation
– Mouse + Shift + x: 2D rotation
– Mouse + c: Zoom in/out
– Mouse + v: Zoom in the specified section

Pan 3D model

3D rotation

Zoom in/out

Zoom in the specified section
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Viewing Operations 4/4

You can change the view emulation mode by right-clicking and selecting 
Tools > Options > Customize.

In order to adjust the center of rotation, click the middle mouse 
button/wheel #2.  This will to make the cursor location center of rotation.

Default Mouse Operations for Viewing (= CATIA V5 mode)

Pan
– Hold the middle mouse button/wheel #2 and drag your mouse.
Rotation (3D) 
– Hold the middle mouse button/wheel #2 and either left mouse button 

#1 or right mouse button #3 and drag your mouse.
Rotation (2D) 
– Operation of "Rotation (3D)" + SHIFT key
Zoom 
– Hold the middle mouse button/wheel #2 and click on either left mouse 

button #1 or right mouse button #3 and drag your mouse
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High-Resolution Display Mode
Toolbars and assembly trees can be displayed with larger icons. This mode is effective when using the XVL Player on a high-
resolution monitor or tablet.

1. Select Tools > Options to open the Options dialog.

2. In the Customize tab, select Use for High-resolution mode.

Larger icons
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Walk Through
Right Click Menu > View Operation Mode > Walk will let you walk 
through the scene.

• Toolbar icons change to Walk Through controls. 

• By selecting View Operation Mode > Examine, you can go back 
to view mode.

Translate

Walk Look Around
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Fly Through
Right Click Menu > View Operation Mode > Fly will let you fly through 
the scene.

• Toolbar icons to the Fly Through controls. 

• By selecting View Operation Mode > Examine, you can go back to 
view mode.

* Whereas the Walk through mode maintains the vertical level, the Fly 
Through mode can change the height of the view (fly up and down).

Translate

Fly Look Around
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Display
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Display Modes

Display Toolbar

Wireframe

Shaded

Shaded + Wireframe

Hidden Line

Display Vertex
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Changing Tessellation
You can adjust tessellation quality according to your environment.

The LOD icon adjusts level of details according to the view.

By zooming in or out, you can see that Player re-tessellates  the 
view.

Display Toolbar

Rough Normal

Fine Extra Fine
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Display Settings
General tab:
– Coordinate system

– Projection

– Material priority

Display Speed/Quality tab:
• Performance settings.

Display Color tab:
• Background settings
• Color settings
• Font settings
• Arrow settings

Switch Display tab:
• Display settings

Hidden Line Display:
• Hidden line display settings
• Illustration display settings

Display Toolbar

Clicking the Display Options icon will bring up the Display Options dialog box:
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Using Color Sets
1. After choosing display colors, you can register the color set by selecting an entry from the Color set dropdown menu and 

clicking the Set button.

2. To reflect the registered color set to the graphic window, select a color set from the Color Set list.

Display Toolbar

* XVL Player will remember the color set.

1

2
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Selecting Objects



© Lattice Technology, Inc. All Rights Reserved. Table of Contents 24

Target Selection
In the toolbar, specify the type of selection to pick the target to work on.

Operation Toolbar

Surface

Vertex Edge

- Select parts

- Select bodies - Select surfaces, vertices, edgesPart selection

Body selection Element selection
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Transparent and Fit Selection
1.Turning on Opaque Selection will make the selected part solid and the other parts transparent.

2.Turning on Transparent Selection will make the selected part transparent and the other parts solid.

3.Turning on Show Selection Parts will display the selected parts only in the graphic window.  

4.Turning on Fit Selection will fit the selected part in the graphic window.  

Transparent Selection Opaque Selection + Fit SelectionOpaque Selection

Operation Toolbar

Show Selected Parts
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Annotation / Dimension Selection
In the toolbar, click the Edit Note / Edit Dimension icon to pick annotations or dimensions.

Operation Toolbar

*  Annotations and dimensions can not be moved after selection.
*  Editing annotations and dimensions requires an XVL Studio license.

Dimension selection

Annotation selection
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Part Display Controls
1. Select the Assembly Tree icon from the Operation Toolbar to show the Assembly Tree.

2. Clicking each node of the tree structure highlights the corresponding element(s).

3. Use + and – to control display of the tree structure.

4. You can select multiple nodes by holding the Ctrl and Shift keys.

5. Switch on and off the check boxes to display or hide each part.

6. Right click on the Assembly Tree to bring up the right-click menu.
a) Shows the selected element.
b) Hides the selected element.
c) Shows the selected element and hides all other elements.
d) Shows all elements.

a
b
c
d

Operation Toolbar
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Displaying Group Properties
1. Select a part on the Assembly Tree.

2. To show the Properties dialog, select Properties…
from the right click menu.
• XVL data contains properties inherited from the 

original CAD system.

* Editing the properties requires an XVL Studio license.

1

2
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Animation
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Playing Animation
1. Switch to View Mode.

2. Click on the Play icon to play the animation.

Animation Toolbar

Ex) Process Animation Icons

Reset Cue (Restart)

Stop

Previous process

Play reverse
Pause

Play

Next process

1

2
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Setting Animation Options
Clicking the Animation Options icon will bring up the Animation Options dialog box:

Animation Toolbar

Play Range:
– Select if you play animation of whole process or selected 

process.
Play Interval:
– Select if you play animation of whole range or step by step.
Step Interval:
– Select if you jump to next process or next task when you click 

Next/Previous Process icon.
Loop:
– Check this when you loop process animation.
Highlight display:
– Specify the settings to highlight parts in process animation.
Path Authoring Processes
– Specify how to display animation trace lines and text alerts.
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Measurement
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Simple Measurement
1. Select the type of measurement from the toolbar.

2. Select target(s).
– As you move your mouse cursor, the corresponding 

points, edges, or faces are highlighted.

3. Choose the measurement method.

4. Adjust the position of the dimension.

Measurement Toolbar

1

2

3

4
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Bounding Box

1. Right-click and select Evaluation > Measure 
Dimension… to display the Measurement/Dimension
dialog.

2. On the Other tab, specify Bounding box of part (xN).
3. Select an element from the graphic window.
4. Click on the Selecting button.
5. XVL Player will create a bounding box with dimensions.

* Additional measurements are available with an XVL Studio 
license.
* NOTE: When the Measurement/Dimension dialog box is open, it 
is possible to move dimensions.

1

3
4

2
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Cross-sectioning
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Creating Cross-sections

1. Select the Create/Edit Cross-section icon from the 
toolbar.

2. Specify the location of the cutting plane from the 
Location list or by using the manipulator.

3. To specify the location of cutting plane numerically, 
select Edit Cross-section > Specify Number… and 
enter the values.

4. Select Edit Cross-section > Create and Display 
Cross-section to create the profile.

Cross-section Toolbar

1

2

3 4
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Displaying Cross-sections

1. Select a profile from the Cross-section List.
2. To display the cross section, select Display Cross-

section.

3. To go back to normal view, select Hide Cross-
section.

4. To display profile lines, select Display Profile Line 
Only.

Cross-section Toolbar

1

2

3
4
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Editing Cross-sections

1. Select a cross-section from the Cross-section List.
2. Select the Create/Edit Cross-section icon from the 

toolbar to start editing.

3. Change the location of cutting plane then select 
Create and Display Cross-section.

3

Cross-section Toolbar

1

2
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Cameras / Layouts / Snapshots
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Applying Cameras

1. Select a camera from the Camera List. 
2. Select Apply from the menu to apply the selected 

camera.

View Toolbar

1

2
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Applying Layouts / Snapshots
Selecting a Layout or Snapshot from the list will apply the selected layout or snapshot to the view. 

Layout Toolbar
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